Questions and Answers

Using Klaros with Apache reverse proxy

Toggle
Hi,
I installed Klaros on our development server. I would like to make url little nicer. I setuped reverse proxy:


123456789101112131415
# mod_proxy setup.
ProxyRequests Off
ProxyPass /klaros-web http://127.0.0.1:18080/klaros-web
ProxyPassReverse /klaros-web http://127.0.0.1:18080/klaros-web

<Location "/klaros-web">
  # Configurations specific to this location. Add what you need.
  # For instance, you can add mod_proxy_html directives to fix
  # links in the HTML code. See link at end of this page about using
  # mod_proxy_html.

  # Allow access to this proxied URL location for everyone.
  Order allow,deny
  Allow from all
</Location>


It almost works, but there is issue with test execution. The pop up window is displaying login dialog instead of actual test case and it doesn't allow to login, so i can't continue executing.

I will appreciate any advice.

regards,
Maciej Sawicki
0 (0 Votes)

RE: Using Klaros with Apache reverse proxy
Answer
1/27/11 4:59 PM as a reply to Maciej Sawicki.
Hi Maciej,

can you please check the parameter "Application URL" in the category "Configure" in Klaros-Testmanagement. You can find it under "System Parameters | General". This parameter must be set to the new proxy URL of Klaros. Without this, Klaros will not work properly when running behind a proxy.

Regards,

Tobias Schmitt
0 (0 Votes)

RE: Using Klaros with Apache reverse proxy
Answer
2/1/11 12:16 PM as a reply to Tobias Schmitt.
Hi Tobias,

Thank You for quick answer. the url wasn't set. After setting it to https://somedomain/klaros-web everything works grate.
0 (0 Votes)