Import Failure

ftm fdl, modified 1 Year ago.

Import Failure

Youngling Posts: 4 Join Date: 11/11/20 Recent Posts
Hello, when I exported the data from the previous version of klaros and then updated it to version 5.0.4, and tried to import this data, klaros refused to import it, a message pops out telling that that the version of the XML file is old. So what to do in this case?
thumbnail
Torsten Stolpmann, modified 1 Year ago.

RE: Import Failure

Jedi Council Member Posts: 715 Join Date: 2/12/09 Recent Posts
Hello ftm,

You find this question already answered here: https://www.klaros-testmanagement.com/forum/-/message_boards/view_message/150011.

Please let me know if this resolves your question or if additional questions arise.

Regards,

Trstn
ftm fdl, modified 1 Year ago.

RE: Import Failure

Youngling Posts: 4 Join Date: 11/11/20 Recent Posts
Hello Torsten, 

Thanks for your quick response.
Regrading the link sent, I had already applied those steps but the same error appears.

the error is: XML version 5.0.2 (Not Compatible with the current database version)



Regards.
thumbnail
Torsten Stolpmann, modified 1 Year ago.

RE: Import Failure

Jedi Council Member Posts: 715 Join Date: 2/12/09 Recent Posts
Ok, just to get this straight:

- Your XML Backup file contains the attribute version="5.0.2" in the top-level klarosExport element
- You are trying to import this file into a Klaros 5.0.2 instance

And then you receive the error message shown?
ftm fdl, modified 1 Year ago.

RE: Import Failure

Youngling Posts: 4 Join Date: 11/11/20 Recent Posts
I have Klaros 5.0.3 installed, when I exported the XML the First line displayed this: "release="5.0.3 - Build 4876 (2020-10-14 19:46:29)" version="5.0.2">"
I need to migrate to a new instance of Klaros on a different server, the version of Klaros installed is 5.0.4 (Which is the newest version) Upon attempting to import I am getting the error that the database version is different, I tried to update my current instance of Klaros however I was worried about losing my data 
thumbnail
Torsten Stolpmann, modified 1 Year ago.

RE: Import Failure

Jedi Council Member Posts: 715 Join Date: 2/12/09 Recent Posts
I have Klaros 5.0.3 installed, when I exported the XML the First line displayed this: "release="5.0.3 - Build 4876 (2020-10-14 19:46:29)" version="5.0.2">"


I checked this with development, this looks inconsistent but is correct so far.

I need to migrate to a new instance of Klaros on a different server, the version of Klaros installed is 5.0.4 (Which is the newest version) Upon attempting to import I am getting the error that the database version is different, I tried to update my current instance of Klaros however I was worried about losing my data 


You need to update your local instance to 5.0.4 and export the backup again in 5.0.4 format to achieve this migration as described in the article I linked to.
This new backup will then be understood by your destination instance.

As a precaution we advise to take a backup of the installation folder and the .klaros folder in your user home folder before updating.
Assuming that you are still using the embedded Apache Database no further steps are required. The update should be straightforward.

I do not know if you are switching to another database on the destination instance (Hint: This is a good point in time to do so).

If this is not the case, you may also transfer the .klaros folder to your destination instance to migrate the complete installation to the other machine.
A restart of Klaros will migrate the installation to 5.0.4 automatically.

Let me know if I can add to this.

Regards,

Torsten
ftm fdl, modified 1 Year ago.

RE: Import Failure

Youngling Posts: 4 Join Date: 11/11/20 Recent Posts
That worked for me! Thank you.

Best regards.
thumbnail
Torsten Stolpmann, modified 1 Year ago.

RE: Import Failure (Answer)

Jedi Council Member Posts: 715 Join Date: 2/12/09 Recent Posts
My pleasure!

Thanks for the feedback, I am happy to see this resolved.

Torsten