Help reg. editing of test steps

Panda Kay, geändert vor 12 Jahren.

Help reg. editing of test steps

Youngling Beiträge: 24 Beitrittsdatum: 02.11.11 Neueste Beiträge
Hi there and Merry Christmas.

I am wondering about a thing regarding editing the text in the test steps.
I do not understand where the problem is, but I do no have this problem in any other place as of yet.

When placing the cursor in a specific spot in a text field to edit test steps, more often than not the text I am typing is not entered into the field or it is, but changed back to what it was before the edit after a couple of seconds.
This goes both when editing letter by letter and when using copy/paste/delete. In addition, many times, if I delete by using backspace, I am navigated back a page in the browser. It doesn't seem to recognize that my cursor is in a text field.

It seems that the blue dots in the top of the web page is inducating that something is in progress almost all of the time, does the application keep auto saving? I have experienced to make a change without saving and coming back to that later and the change was saved.

Have you heard of this editing issue before?
This is regarding CE3.4.7, but I run the UI in IE9 on a Win7 Enterprise 64bit.

I haven't tried updating to the latest version yet, as the person on whose account the webserver is running, is on vacation. I will try this in the middle days to see if it helps, but I am not experiencing this issue other places.

BTW, the same problem occurs in Firefox 9.

Hope you will have a wonderful Christmas time. emoticon
sven finsterwalder, geändert vor 12 Jahren.

RE: Help reg. editing of test steps

Padawan Beiträge: 28 Beitrittsdatum: 25.05.11 Neueste Beiträge
We have the same behavior on our 3.4.8 klaros and yes we saw also the blue dots in the top doing something. And after that the changes are lost.
Torsten Stolpmann, geändert vor 12 Jahren.

RE: Help reg. editing of test steps

Jedi Council Member Beiträge: 756 Beitrittsdatum: 12.02.09 Neueste Beiträge
The steps page is different due to the two alternate views on the data it displays (tabbed vs non-tabbed mode).

I have spotted and fixed at least one issue which is related to potential stale data when switching between these views, this fix should be available later this week.

The application is communicating dirty state when activating/deactivating text fields so this is what is triggering the communication activity. Under normal circumstances this should not be noticeable. If you are loosing input in the way you described you should definitely avoid typing until communication is finished.

We are very much interested in finding the root cause for the delays if this is the culprit. I was not yet able to reproduce the described behavior.